Can't resolve hostname

Discussion in 'Get Help!' started by The_Masterpug, Mar 3, 2019.

Thread Status:
Not open for further replies.
  1. Yay! Happy Late New Year, oops! I have started playing Minecraft again (woohoo!) & since I got a new Apple Mac, the Sandlot Server isn't working. I am continuing to get "Can't resolve hostname" repetitively" on my server list. Is there anything I can do? The new Sandlot sounds great! I hope 2019 is a much better year for you C0w :D

    ~~~ Pug xoxo
     
  2. BetaStrawberry

    BetaStrawberry |Majestic| VIP

    Hmm. Try connecting using the direct IP address: 142.4.217.143.

    What version are you in? Try 1.12.1 or 1.12.2
     
  3. c0wg0d

    c0wg0d Master Owner Moderator VIP

    Make sure you use server.sandlotminecraft.com as the server address. If that's correct, then it sounds like a problem with your internet service provider.
     
  4. isannor

    isannor Adept

    It could also be a port that the sandlot uses is blocked by your firewall (this happened to me when I used realms)
     
  5. __Excel

    __Excel Professional cat petter VIP

    Firewalls do not usually default to blocking ports, especially not outgoing ones... that would only be if they had intentionally changed something, or downloaded malware which change the firewall settings. Plus if it blocked 25565 then they wouldn't be able to connect to almost all minecraft servers.
     
  6. I've tried that in both 1.12.1 & 1.12.2. Seems to not be working
    I guess when I return back to my holiday house (my old mac) I can play on the Sandlot :(
    Thanks
    ~~~ Pug xoxo
     
  7. Tried that too, & still not working.D:
     
  8. BetaStrawberry

    BetaStrawberry |Majestic| VIP

    Is this just the Sandlot or other servers too?
     
  9. Just the Sandlot unfortunately =C
     
  10. BetaStrawberry

    BetaStrawberry |Majestic| VIP

    Wow.. that's odd. Try it in 1.13.1? I think it may be your internet connection, and something is blocking the Sandlot? Did you try the direct IP address with the numbers?
     
  11. SheerLuckHolmes

    SheerLuckHolmes At your service

    Ok, here goes a lot of technical stuff.
    The error "Can't resolve hostname" indicates that your DNS Servers (domain name servers) are failing to respond during the test cycle. This can be fixed in a variety of different ways, using a different DNS being a common one, but can be difficult to pull off for someone who doesn't know low level OS well. A possible issue could be that the data file containing your server info has corrupted, in which case I would try and delete the server off your server list, then remake it. That should erase previous data and overwrite it with correct information. Typically when a DNS server stops working, you will still be able to connect for around 24 hours after your last connection due to ISP and OS caching the proper IP for a brief time after you connect to them. If direct connect and rewriting the server to minecraft files doesn't work, talk to your parents about adding CloudFlare's extremely fast DNS server (1.1.1.1) to your list in:

    Apple menu in top left > System preferences > Network > Select your interface (Ethernet if your internet is wired, Wi-Fi if wireless) > Click the advanced button in the bottom right > click the "DNS" tab on the top of the window > click the + button in the bottom left > type in "8.8.8.8" without the " and then hit enter > click "Ok" in the bottom right > click "Apply" > Close system preferences

    Do NOT do this without talking to parents first, and if you end up taking this route but don't understand something, send me a message and I will get back to you as soon as I can with more detail.

    I hope this helps, and have a wonderful day/night!
     
    Last edited: Mar 10, 2019
    • Like Like x 1
  12. __Excel

    __Excel Professional cat petter VIP

    Couple of notes that might help you sum up the post:
    You can try to fix this by doing one of the following:
    1) clear you DNS cache (google it): this would be for the case that something went wrong in the cache.

    2) like @SheerLuckHolmes said, add super fast DNS servers to your list: but use the address 1.1.1.1 . Google tends to keep information about your requests, and (like with everything else it does) it snoops you. 1.1.1.1 is a non profit organization that I believe is sponsored by cloudflare.

    Plus some things sheerluckholmes didn't say:
    3) ask your parents if they have a proxy/switch connected to your router: your parents may have install a virtual proxy to keep the network in the house safe (I know my father installed a virtual one named openDNS, which would block suspicious requests). If they do have one installed, it might block the sandlot. Try asking them to get the sandlot ip whitelisted.

    4) Anti-virus software: like #3 if you have installed anti virus software on your computer, ask your parents to try and whitelist the sandlot.

    If none of that works, I'm afraid we can't help you very much over the internet (I would want to check wireshark logs to see where the requests are going, and doing that would not be a good idea on public forums, plus I think it would violate some of the rules).
     
    • Like Like x 1
    • Agree Agree x 1
  13. __Excel

    __Excel Professional cat petter VIP

    Important: what error did you get when using the direct IP (142.4.217.143)?
     
  14. SheerLuckHolmes

    SheerLuckHolmes At your service

    Thank you so much for mentioning this, I completely forgot about CloudFlare's DNS server (which incidentally is what I use on my laptop) so I just googled fast DNS servers and of course, since it's google, it gave me their server (I was on a friend's PC when I made the post.) Edited my post to fix this issue.
    I didn't mention this because Pug used to be able to connect. Might still be the issue though, they could have installed one afterwards or an update could have happened.
    If only this were legal... (Technically it is if you have permission, but good luck getting permission from people online)
    Also, the problem with clearing DNS cache is that most of the time your ISP will also cache it, and if their TTL is high then it might take a while to fix. But also this -> [sudo killall -HUP mDNSResponder; echo macOS-DNS-Cache-Clear]
     
  15. Hooray! Finally worked! Thank you, everyone, sooo much!

     
    • Like Like x 3
  16. BetaStrawberry

    BetaStrawberry |Majestic| VIP

    Yay! We got there in the end! Hope to see you having fun on the Sandlot very soon! :)
     
  17. __Excel

    __Excel Professional cat petter VIP

    Great!
    Yeah I meant that if I were with them in person then I would ask to check.
    Also I didn't know that ISPs cache DNS requests, but I guess that makes a lot of sense.
     
Thread Status:
Not open for further replies.